Failed to add CIFS with error code#124: Mount filesystem error

Product: Vinchin Backup & Recovery

Version: V9.0

KB Number: 200222

Last Modified: 2026-09-29 23:20:01

 


Question

We are unable to mount the Vinchin version 9 share on our NAS storage—neither via iSCSI nor SMB.

The CIFS storage validity check failed, error code: #124, error description: Error mounting the file system.

Answer

Issue Description

please excute command "dmesg | grep -i cifs" on the vinchin backend for check.

If the output is:

CIFS: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3.1.1), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3.1.1 (or even SMB3 or SMB2.1) specify vers=1.0 on mount.

It means SMB protocol version mismatch between the client and the server.


Resolution

please login QNAP and open[ControlPanel]->[Network&FileServices]->[Win/Mac/NFS/WebDAV]->[Advanced Options],Set the highest SMB version to SMB 3 and the lowest SMB versionto SMB 2.Then try to add the CIFS Share again.

Qnap

60-DAY FULL-FEATURED FREE TRIAL

  • No credit card required
  • Get started in 10 minutes