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Overview 

This documentation is intended to instruct data center system administrators through the process 

of installing and deploying Vinchin Backup & Recovery to construct your data center backup 

infrastructure.  

Vinchin Backup & Recovery contains the following components: 

⚫ Vinchin Backup & Recovery Server (hereinafter called Vinchin Backup Server)

⚫ Vinchin Backup & Recovery Node (hereinafter called Vinchin Backup Node)

⚫ Vinchin Backup & Recovery Proxy (hereinafter called Vinchin Backup Proxy)

Among the 3 infrastructure components, Vinchin Backup Server is the primary infrastructure 

component which needs to be installed to protect your virtual and hybrid environments. Vinchin 

Backup Node and Vinchin Backup Proxy are optional components. 

Vinchin Backup Node is needed only for backup and restoration of large-scale virtual 

infrastructures. It is used to decentralize the workload of the Backup Server. 

Vinchin Backup Proxy is supported by Vinchin Backup & Recovery v6.0 and v6.5/v6.7 , and it is

dedicated for VMware vSphere virtual infrastructure without a Storage Area Network (SAN). It 

needs to be installed on the vSphere ESX/ESXi server as a virtual machine, to improve the 

backup and restore efficiency.  

Both Vinchin Backup Server and Backup Node are recommended to be installed on physical 

machines. While Vinchin Backup Proxy needs to be installed on VMware vSphere ESX/ESXi server 

as a virtual machine. 
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System Requirements 

Physical Machine Requirements for Backup Server and Backup Node 

No Hardware Requirement 

1 CPU 2*Intel Xeon E5 (2.5GHz, 4 cores, 8 threads or higher) 

2 RAM 32GB or more 

3 Network 2*10Gbps Base-T RJ45 ports or more 

4 OS Disk 2*100GB SSD 

5 OS Disk RAID Level RAID 1 

6 Backup Disk 1.5 times (or more) capacity of the production data size, 

if other storage media will be used as backup storage, 

then backup disk is not required. 

7 Backup Disk RAID Level RAID 5 

8 Fibre Channel HBA (optional) 8Gb Fibre Channel or faster 

Virtual Machine Requirements for Backup Server and Backup Node 

*(For evaluation only) 

No Hardware Requirement 

1 CPU 4*vCPUs or more 

2 RAM 8GB or more 

3 Guest OS CentOS 7 Linux (64-bit) 

4 Virtual Disk 1 100GB or more (for OS installation) 

5 Backup Storage 1.5 times (or more) capacity of the production data size; 

Please do not use virtual disk as backup storage, you can use external 

NAS server or other storage servers to provide iSCSI or NFS shares to 

Vinchin Backup server as backup storage. 

Virtual Machine (VMware) Requirements for Backup Proxy 

No Hardware Requirement 

1 CPU 4*vCPUs or more 

2 RAM 8GB or more 

3 Guest OS CentOS 7 Linux (64-bit) 

4 Virtual Disk 50GB or more (for system volume only) 
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Download ISO Image 

Vinchin Backup Server 

Go to Vinchin product trial page using the link below: 

https://www.vinchin.com/en/support/vm-backup-free-trial.html 

Simply register for your free trial with your full name, Email address and your hypervisor name. 

Then the latest ISO image will be downloaded automatically, at the same time you’ll receive an 

Email with a 60-day free trial license attached. 

Please keep the free trial license safe, as after installation you’ll need it to activate Vinchin Backup 

Server for 60 days of full-featured free trial. 

Vinchin Backup Node and Proxy 

The download link of Vinchin Backup Node is as below: 

https://www.vinchin.com/download/node/latest 

The download link of Vinchin Backup Proxy is as below: 

https://www.vinchin.com/download/proxy/latest 

https://www.vinchin.com/en/support/vm-backup-free-trial.html
https://www.vinchin.com/download/node/latest
https://www.vinchin.com/download/proxy/latest
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Prepare Installation Media for Physical Machine 

If you have IPMI remote access to your server like iDRAC, then you can skip this bootable ISO 

preparation part, go to installation part directly. 

The installation of Vinchin Backup Server and Vinchin Backup Node on physical machines can be 

done either by using a USB flash drive or the DVD drive on the physical machine.  

To create a bootable USB drive or DVD, you can use UltraISO (for Windows), or you can use any 

other creator which you are familiar with.  

To download UltraISO please go to its download page: https://www.ultraiso.com/download.html 

Below are instructions of how to create bootable USB drive and bootable DVD, choose either way 

which you prefer to prepare the installation media. 

Create Bootable USB Drive 

Prepare a 4GB or larger USB drive, and backup all data of the USB drive before you start to create 

bootable USB drive with it.  

Attach the USB drive to your Windows PC and run UltraISO. 

Open the ISO image from File > Open menu. 

Then choose Bootable > Write Disk Image and then click Write to start creating the bootable USB 

drive. 

It will take a few minutes to write all necessary data to the USB drive, please wait patiently for the 

whole process to be completed. 

https://www.ultraiso.com/download.html
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Burn Bootable DVD 

Make sure your Windows PC has a working R/W DVD drive. Otherwise, attach an external USB DVD 

drive. Insert a blank or rewritable DVD into your DVD drive. 

Run UltraISO, and open the ISO image from File > Open menu. 

Then choose Tools > Burn CD/DVD image, set the Write Speed to the lowest speed and then click 

on Burn button to start burning the bootable DVD. 

It will take a few minutes to write the ISO image to the DVD, please wait patiently until the process 

to be completed. 

For both Vinchin Backup Server and Vinchin Backup Node, you can create the installation media 

the same way by using the corresponding ISO image. After you have created the installation media, 

then you can proceed to install. 
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Physical Machine Installation 

No matter you choose to install Vinchin Backup Server or Backup Node from USB drive, or DVD 

drive, or iDRAC, the installation processes are the same. Please follow the instructions below to 

complete the installation. 

If you are going to install both Vinchin Backup Server and Backup Node, it is recommended to install 

Vinchin Backup Server first, then to install Backup Node. 

Vinchin Backup Server Installation 

Here take Dell PowerEdge R620 for example, let’s see how to install Vinchin Backup Server on 

physical machine with iDRAC. 

Preparations before Starting the Installation. 

1. Log in iDRAC with administrative information.
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2. Launch the Virtual Console.

3. Select Virtual Media > Map CD/DVD.
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Open and select the Vinchin Backup Server ISO image. 

Click Map Device. 
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4. Click Next boot > Virtual CD/DVD/ISO.

5. Click Power > Reset system (warm boot).

Click Yes. 
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Vinchin Backup Server Installation Wizard 

1. After restart the server, here we are in Vinchin Backup Server installation process. Please

choose Install CentOS 7 and press Enter.

2. On the INSTALLATION SUMMARY screen, a few settings need to be completed. Please select

Date & time to set the system time zone.
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Select the Time Zone where you are located in and click Done.

3. Click on INSTALLATION DESTINATION to select the system disk for installation.
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Here we select the OS disk and choose the default partitioning strategy, then click Done to 

continue. 

Note 

If you have more than one disk, please make sure that only one target disk is selected as system 

disk (the others used as data disk and the system disk CAN’T be used as data disk). 

4. Click NETWORK & HOST NAME to configure network settings.



Set Host name, e.g., vinchin.com for Vinchin Backup Server, then click Apply. 

To set the network profiles, click on Configure...  

Click on IPv4 Settings tab to configure the network profiles. 

Method: Manual (it’s recommended to configure a static IP address to the Backup Server). 

Then click on Add to manually configure the network profiles. And in the DNS servers field, 

insert a valid DNS server IP.  

When done, click on Save. 
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Enable the network adapter and then click Done. 

5. Now simply click on Begin Installation to start the installation process.

Note 

It will take several minutes to complete the installation process, please do not power off or 

restart the server. 

6. When the installation is completed, please remove the USB drive or DVD, or disconnect virtual

media, then click on Reboot.
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After rebooting, the whole installation process is completed. 

Note 

It will take several minutes to complete rebooting, because Vinchin software will be installed 

during the first reboot. Please don't power off or restart the server, otherwise the installation 

of Vinchin software will fail.   
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Vinchin Backup Node Installation (Optional) 

If there are more than 200 virtual machines, or the amount of production data is more than 50TB. 

You can consider deploying Vinchin Backup Node to share the workload with Backup Server. 

The installation of Vinchin Backup Node is quite similar to Vinchin Backup Server installation. 

Please refer to the Vinchin Backup Server Installation section to install your Vinchin Backup Node. 

Please use a new IP address and host name during the Backup Node installation. 

After installation, the Backup Node needs to be restarted. When you see the command line login 

prompt. Please log in the command line interface using the below credentials: 

Username: root 

Password: Backup@3R 

Then please configure the Backup Node to be connected to the Backup Server with below 

command:  

# config_server 

Then type in the IP address of the Backup Server and press Enter. 

Now the Backup Node needs to be restarted, please type Y and then press Enter. 

After rebooting, Vinchin Backup Node will be successfully connected to Vinchin Backup Server. And 

by now, the Backup Node had been successfully deployed, no further settings need to be done 

from the Backup Node side, as it will be managed by the Backup Server from now on. 
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Virtual Machine Installation 

Vinchin Backup Server and Backup Node Installation 

To install Vinchin Backup Server or Backup Node on the hypervisor as virtual machines, please refer 

to the System Requirements section for virtual machine configurations of both Vinchin Backup 

Server and Vinchin Backup Node.  

If your Vinchin backup server is installed as a VM, it's not recommended to install a Vinchin backup 

node VM to expand the backup infrastructure. You can choose to upgrade the backup server VM 

configurations, or to install backup node on a physical machine to expand the backup infrastructure. 

Installing Backup node as virtual machine can only be used for evaluation.  

Creating a new virtual machine on the hypervisor. The guest OS of new virtual machine should be 

Linux, and the version should be CentOS 7. 

And the virtual CD/DVD drive should be configured to point directly to the Vinchin Backup Server 

or Backup Node ISO image file. 

For the detailed installation process instructions of Vinchin Backup Server, please refer to Vinchin 

Backup Server Installation. For the detailed installation process of Vinchin Backup Node, please 

refer to the Vinchin Backup Node Installation. 

Vinchin Backup Proxy Installation (Optional) 

Vinchin Backup Proxy is dedicated for VMware vSphere virtual infrastructure without a storage 

area network. It needs to be installed on the vSphere ESX/ESXi server as a virtual machine. If you 

are using other hypervisors, please DO NOT install Backup Proxy. There’s no need to deploy the 

Vinchin Backup Proxy if you install Vinchin Backup Server on VM. 

Before installing Vinchin Backup Proxy, please review the requirements. 

And the virtual CD/DVD drive should be configured to point directly to the Vinchin Backup Proxy 

ISO image file. 

The installation process of Vinchin Backup Proxy is quite similar to Vinchin Backup Server 

installation. Please refer to the Vinchin Backup Server Installation section to install your Vinchin 

Backup Proxy. 
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Basic Settings 

Web Console Login 

Only Vinchin Backup Server has management web console. Both Vinchin Backup Node and Backup 

Proxy have no web console, they will be managed by Vinchin Backup Server. 

Use your web browser (Google Chrome is recommended) to open Vinchin Backup Server web 

console by using the IP address that you have configured during the installation.  

Use the default credentials to log in. 

Default username: admin 

Default password: 123456 

Change Admin Password 

After you have logged in to the Vinchin Backup Server web console, we recommend you to modify 

the admin password at first priority for backup server safety.  

Click on admin > Change Password to change the default password. 
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The suggested new password should be at least 6 characters, and should consist of uppercase and 

lowercase letters and numerals. And please remember your new password carefully. 

Add Backup Proxy to Vinchin Backup Server 

If you have installed Vinchin Backup Proxy, to associate the Backup Proxy with Backup Server, 

please go to VM Backup > Backup Proxy screen. 

Click on Add to add the Backup Proxy. 

Simply input the IP address of the Backup Proxy in the IP/Domain field. 

Give it a name for identification in the Name field.  

The port number should not be changed. 

Click on OK to add the Vinchin Backup Proxy to the Vinchin Backup Server. 
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License 

Before you start testing Vinchin Backup & Recovery products, please upload the trial license we 

sent you by email after you have registered to download Vinchin Backup Server installation ISO 

image. It is a 60-day full featured trial license key. 

To upload a license key, please go to System > System License page. 

Click on Upload License to browse the free trial license, and then upload it to activate Vinchin 

Backup Server for a 60-day evaluation. 

If you wish to buy perpetual license for Vinchin Backup & Recovery, please contact our sales team. 

Please find our contact information on the last page on this document. 
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Head Office 

F5, Block 8, National Information Security 

Industry Park, No.333 YunHua Road, 

High-Tech Zone, Chengdu, China. 

P.C.610041

Sales 

Tel: +86-135-5029-3426 

Email: sales@vinchin.com 

Support 

Tel: +86-159-2884-8843 

Email: technical_support@vinchin.com 

Website 

www.vinchin.com 




