
 

 

!"#$%"#&'($)*+&,&-.$/0.12&
0345&
 

!"#$%&&%$'(")*+',-)

)
!"!"#"$%



 

VINCHIN Backup & Recovery | Quick Installation Guide V4.0 

 

Table of Contents 
Overview .......................................................................................................................................... 1 
Recommended Installations ............................................................................................................ 2 
System Requirements ...................................................................................................................... 3 

Physical Machine Configuration for Backup Server and Backup Node .................................... 3 
Virtual Machine Configuration for Backup Server and Backup Node ...................................... 3 
Virtual Machine (VMware) Configuration for Backup Proxy .................................................... 3 

Download ISO Image ........................................................................................................................ 4 
Vinchin Backup Server ............................................................................................................. 4 
Vinchin Backup Node and Proxy .............................................................................................. 4 

Prepare Installation Media for Physical Machine ............................................................................. 5 
Create Bootable USB Drive ....................................................................................................... 5 
Burn Bootable DVD .................................................................................................................. 6 

Physical Machine Installation ........................................................................................................... 7 
Vinchin Backup Server Installation ........................................................................................... 7 
Vinchin Backup Node Installation .......................................................................................... 13 

Virtual Machine Installation ........................................................................................................... 14 
Vinchin Backup Server and Backup Node Installation ............................................................ 14 
Vinchin Backup Proxy Installation .......................................................................................... 14 

Basic Settings ................................................................................................................................. 15 
Web Console Login ................................................................................................................. 15 
Change Admin Password ........................................................................................................ 15 
Add Backup Proxy to Backup Server ...................................................................................... 16 
License ................................................................................................................................... 17 

 
 

  



 

Vinchin Backup & Recovery | Installation Guide V6.0 | 1 

Overview 

This guide is intended to instruct data center system administrators of how to install and setup 
Vinchin Backup & Recovery products.  
There are 3 infrastructure components (Vinchin Backup & Recovery products) that can be used to 
construct your data center backup infrastructure. 
l Vinchin Backup & Recovery Server 
l Vinchin Backup & Recovery Node 
l Vinchin Backup & Recovery Proxy  
Among these 3 infrastructure components, Vinchin Backup & Recovery Server (hereinafter called 
Vinchin Backup Server) is the primary infrastructure component which needs to be installed to 
protect your virtual and hybrid environments. Vinchin Backup & Recovery Node (hereinafter 
called Vinchin Backup Node), Vinchin Backup & Recovery Proxy (hereinafter called Vinchin 
Backup Proxy) are optional components. 
Vinchin Backup Node is needed only for backup and restoration of large scale virtual 
infrastructures. It is used to decentralize the work load of the Backup Server.  
Vinchin Backup Proxy is supported by Vinchin Backup & Recovery v6.0, and it is dedicated for 
VMware vSphere virtual infrastructure without a Storage Area Network (SAN). It needs to be 
installed on the vSphere ESX/ESXi server as a virtual machine, to improve the backup and restore 
efficiency.  
Both Vinchin Backup Server and Backup Node are recommended to be installed on physical 
machines. While Vinchin Backup Proxy needs to be installed on VMware vSphere ESX/ESXi server 
as a virtual machine. 
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Recommended Installations 

Please refer to the following recommended installation scenarios to install Vinchin products for 
actual production deployments or testing deployments. 
 
l Installation Scenario #1:  

Ø Standalone Vinchin Backup Server (physical machine) 
Standalone Vinchin Backup Server installation on a physical machine is suitable for small and 
medium size virtual infrastructures backup and recovery. 
 
l Installation Scenario #2: 

Ø Vinchin Backup Server (physical machine) 
Ø Vinchin Backup Node (physical machine) 

If there are more than 200 virtual machines, or the amount of production data is more than 50TB. 
You can consider deploying Vinchin Backup Node to share the work load with Backup Server. 
 
l Installation Scenario #3 (VMware vSphere only): 

Ø Installation Scenario #1 + Vinchin Backup Proxy (virtual machine) 
Ø Installation Scenario #2 + Vinchin Backup Proxy (Virtual Machine) 

If your virtual infrastructure is VMware vSphere and there’s no SAN storage, based on the 
Installation Scenario #1 and #2, you can install Vinchin Backup Proxy on the VMware vSphere 
ESX/ESXi server as a virtual machine to take advantage of the ESX/ESXi server’s Hot Add 
technology to improve the efficiency of backup and recovery. 
Note 
Please DO NOT install Vinchin Backup Server on VMware vSphere virtual infrastructure as virtual 
machine, if you decide to deploy Vinchin Backup Proxy in your production or testing environment, 
as this installation cannot improve the efficiency of backup and recovery. 
 
l Installation Scenario #4: 

Ø Vinchin Backup Server (virtual machine) 
If you decide to install Vinchin Backup Server on the hypervisor as a virtual machine, then Vinchin 
Backup Node is not needed to be installed. 
 
l Installation Scenario #5 (Testing purpose only): 

Ø Vinchin Backup Server (virtual machine) 
Ø Vinchin Backup Node (virtual machine) 

To install both Vinchin Backup Server and Backup Node on the hypervisor as virtual machines is 
not recommended for an actual deployment of your backup infrastructure. It is only 
recommended for testing Vinchin products. 
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System Requirements 

Physical Machine Configuration for Backup Server and Backup Node 

Recommended hardware configurations for both Vinchin Backup Server and Backup Node are as 
follows: 
l CPU:     6 cores or more 
l RAM:     16GB or more 
l NIC:     1Gbps or faster 
l Disk:     100GB or more (for system volume only) 
l Data Storage:   The supported storage types including local partition, local disk, 

     local directory, LVM, FC, iSCSI, NFS, CIFS. The storages can be added 
     after the installation of the Backup Server. 

 

Virtual Machine Configuration for Backup Server and Backup Node  

Recommended virtual machine configuration for Vinchin Backup Server and Backup Node are as 
follows: 
l CPU:     6 cores or more 
l RAM:     16GB or more 
l Disk:     100GB or more (for system volume only) 
l Data Storage:   iSCSI, NFS, CIFS recommended 
 

Virtual Machine (VMware) Configuration for Backup Proxy 

Recommended vSphere ESX/ESXi virtual machine configurations for Vinchin Backup Proxy: 
l CPU:    4 cores or more 
l RAM:    8GB or more 
l Disk:    50GB or more (for system volume only) 
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Download ISO Image 

Vinchin Backup Server 

Go to Vinchin product trial page using the link below: 
https://www.vinchin.com/en/support/vm-backup-free-trial.html 
Simply register for your free trial with your full name, Email address and your hypervisor name. 
Then the downloading will start automatically, at the same time you’ll receive an Email with a 
60-day free trial license attached. 
Please keep the free trial license safe, as after installation you’ll need it to activate Vinchin 
Backup Server for 60 days of full-featured free trial. 
 

Vinchin Backup Node and Proxy 

The download link of Vinchin Backup Node is as below: 
https://www.vinchin.com/download/node/latest 
 
The download link of Vinchin Backup Proxy is as below: 
https://www.vinchin.com/download/proxy/latest 
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Prepare Installation Media for Physical Machine 

The installation of Vinchin Backup Server and Backup Node on physical machines can be done 
either by using a USB flash drive or the DVD drive on the physical machine.  
To create a bootable USB drive or DVD, you can use UltraISO (for Windows), or you can use any 
other creator which you are familiar with.  
To download UltraISO please go to its download page: https://www.ultraiso.com/download.html 
Below are instructions of how to create bootable USB drive and bootable DVD, choose either way 
which you prefer to prepare the installation media. 
 

Create Bootable USB Drive 

Prepare a 4GB or larger USB drive, and backup all data of the USB drive before you start to create 
bootable USB drive with it.  
Attach the USB drive to your Windows PC and run UltraISO. 
Open the ISO image from “File” -> “Open” menu. 
Then choose “Bootable” -> “Write Disk Image” and then click “Write” to start creating the 
bootable USB drive. 

 
It will take a few minutes to write all necessary data to the USB drive, please wait patiently for 
the whole process to be completed. 
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Burn Bootable DVD 

Make sure your Windows PC has a working R/W DVD drive. Otherwise, attach an external USB 
DVD drive. Insert a blank or rewritable DVD into your DVD drive. 
Run UltraISO, and open the ISO image from “File” -> “Open” menu. 
Then choose “Tools” -> “Burn CD/DVD image”, set the “Write Speed” to the lowest speed and 
then click on “Burn” button to starting burning the bootable DVD. 

 
It will take a few minutes to write the ISO image to the DVD, please wait patiently until the 
process to be completed. 
 
For both Vinchin Backup Server and Vinchin Backup Node, you can create the installation media 
the same way by using the corresponding ISO image. After you have created the installation 
media, then you can proceed to install. 
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Physical Machine Installation 

No matter you choose to install Vinchin Backup Server or Backup Node from USB drive or DVD 
drive, the installation process is the same. Please follow the instructions below to complete the 
installation. 
If you are going to install both Vinchin Backup Server and Backup Node, it is recommended to 
install Vinchin Backup Server first, then to install Backup Node. 
 

Vinchin Backup Server Installation 

Power on the physical server, and attach the bootable USB drive to the USB interface of the 
server, or insert the DVD into the DVD drive of the server. 
Set the server to legacy BIOS boot mode. And then configure the boot sequence, the USB drive or 
DVD drive (depending on the installation media you want to use) should be set as the first boot 
option. After this, restart the server and now it should enter the Vinchin Backup Server 
installation process. 

 
Choose “Install CentOS 7” and press Enter. 
On the “INSTALLATION SUMMARY” screen, a few settings need to be done before installation. 
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Please select “DATE & TIME” to set the system time zone. 

 
 
Select the time zone which you are located in and click “Done”. 
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Next, click on “INSTALLATION DESTINATION” to select the target disk for installation. 

 
 
Select the target disk, and you can choose “Automatically configure partitioning” to let the 
system automatically do the partitioning. Or if you have other plans with the disk, you can choose 
“I will configure partitioning” to manually configure the disk partitioning.  
Here we choose the default partitioning strategy, and click “Done” on the top left to continue. 
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Next, network settings need to be configured, please click on “NETWORK & HOST NAME”. 

 
 
Set “Host name”, e.g. ‘vinchinbackup.server’ for Vinchin Backup Server, then click “Apply”, and 
then click on “Configure…” to set the network profiles. 
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Click on the “IPv4 Settings” tab to configure the network profiles. 

 
“Method” should be configured as “Manual”, this will allow you to configure a static IP address 
to the Backup Server/Backup Node. Then click on “Add” to manually configure the network 
profiles. And in the “DNS servers” field, insert a valid DNS server IP. When done, click on “Save”. 
 
Enable the network adapter and then click “Done”. 
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Now simply click on “Begin Installation” to start the installation process. 

 
 
It will take several minutes to complete the installation process, during this, please do not power 
off the server. When the installation is completed, please remove the USB drive or DVD, and then 
click on “Reboot”. 

 

After rebooting, the whole installation process is completed. 
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Vinchin Backup Node Installation 

The installation of Vinchin Backup Node is the same as Vinchin Backup Server installation. Please 
refer to the Vinchin Backup Server Installation section to install your Vinchin Backup Node. 
Please use a new IP address and host name during the Backup Node installation. 
 
After installation, the Backup Node needs to be restarted. When you see the command line login 
prompt. Please log in to the command line interface using the below credentials: 
Username: root 
Password: Backup@3R 

 

 
Then please configure the Backup Node to be connected to the Backup Server. Please use 
command:  
# config_server 

 

Then type in the IP address of the Backup Server and press Enter. 
Now the Backup Node needs to be restarted, please type ‘y’ and then press Enter. 
 
After rebooting, Vinchin Backup Node will be successfully connected to Vinchin Backup Server. 
And by now, the Backup Node had been successfully deployed, no further settings need to be 
done from the Backup Node side, as it will be managed by the Backup Server from now on. 
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Virtual Machine Installation 

Vinchin Backup Server and Backup Node Installation 

To install Vinchin Backup Server or Backup Node on the hypervisor as virtual machines, please 
refer to the System Requirements section for virtual machine configurations of both Vinchin 
Backup Server and Vinchin Backup Node. Then create new virtual machine on the hypervisor. 
The new virtual machine guest OS should be Linux, and the version should be CentOS 7. 
And the CD/DVD drive should be configured to point directly to the Vinchin Backup Server or 
Backup Node ISO image file. 
For the detailed installation process instructions of Vinchin Backup Server, please refer to Vinchin 
Backup Server Installation. For the detailed installation process of Vinchin Backup Node, please 
refer to the Vinchin Backup Node Installation. 
 

Vinchin Backup Proxy Installation 

Vinchin Backup Proxy is dedicated for VMware vSphere virtual infrastructure without a storage 
area network. It needs to be installed on the vSphere ESX/ESXi server as a virtual machine. If you 
are using other hypervisors, please do not install Backup Proxy. 
To install Vinchin Backup Proxy, please create a virtual machine with the VMware vSphere New 
Virtual Machine wizard.  
4 CPU cores, 8GB RAM and 50GB Disk is recommended. 
In “Select a guest OS” section, Guest OS Family should be Linux and Guest OS Version should be 
CentOS 7 Linux (64-bit). 
And the CD/DVD drive should be configured to point directly to the VInchin Backup Proxy ISO 
image file. 
The installation process of Vinchin Backup Proxy is the same as Vinchin Backup Server installation. 
Please refer to the Vinchin Backup Server Installation section to install your Vinchin Backup Proxy. 
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Basic Settings 

Web Console Login 

Only Vinchin Backup Server has management web console. Both Vinchin Backup Node and 
Backup Proxy have no web console, they will be managed by Vinchin Backup Server. 
Use your web browser (Google Chrome is recommended) to open Vinchin Backup Server web 
console by using the IP address that you have configured during the installation.  

 
Use the default credentials to log in. 
Default username: admin 
Default password: 123456 
 

Change Admin Password 

After you have logged in to the Vinchin Backup Server web console, we recommend you to 
modify the admin password at first priority for backup server safety.  
Click on “admin” user icon on the top right, then select “Change Password” to change the default 
password. 
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The suggested new password should be at least 6 characters, and should consist of uppercase 
and lowercase letters and numerals. And please remember your new password. 
 

Add Backup Proxy to Backup Server 

If you have installed Vinchin Backup Proxy, to associate the Backup Proxy with Backup Server, 
please go to “Resources” -> “Proxy” screen. 

 
Click on “+Add” to add the Backup Proxy. 

 
Simply input the IP address of the Backup Proxy in the “IP/Domain” field. 
Give it a name for identification in the “Name” field.  
The port number should not be changed. 
Click on “OK” to add the Backup Proxy to the Backup Server. 
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License 

Before you start testing Vinchin Backup & Recovery products, please upload the trial license we 
sent you by Email, when you have registered to download Vinchin Backup Server installation ISO 
image. It is a 60-day full featured trial license key. 
To upload a license key, please go to “System” -> “System License” page. 

 
Click on “Upload License” to locate the free trial license, and then upload to activate Vinchin 
Backup Server for a 60-day testing and evaluation. 
 
If you wish to buy perpetual license for Vinchin Backup & Recovery, please contact our sales team. 
Please find our contact information on the last page on this document. 
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